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How to use this manual 

The compareDocs User Manual includes the following sections: 

 Product overview – Provides an introduction to the compareDocs user interface; 

 Getting started – Provides information on the user interface and using compareDocs; 

 Integrations – Provides information on using compareDocs with system integration to Document 

management systems; and 

 Technical information – System and supplementary software requirements for compareDocs 

workstations. 
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Product overview 

compareDocs is a document comparison solution and a member of the DocsCorp suite of products.  

compareDocs utilizes the latest document comparison technology. 

compareDocs not only offers integration with Microsoft® Word, Microsoft® Outlook and the most 

widely used document management systems, but also adds a whole new dimension to the DocsCorp  

suite of products. 

When installed with pdfDocs, documents located in the pdfDocs Organizer can be compared at the 

click of a button.  Further, compareDocs takes advantage of Microsoft® Word’s native ‘Track Changes’ 

functionality to enable instant and efficient review of the comparison result in a format familiar to 

you.  compareDocs allows you to accept and reject changes within the comparison result, making it an 

extremely intuitive solution to become familiar with and use. 

Further, when installed with OCR Server or enabled for OCR Desktop, PDF documents can be 

seamlessly converted into Microsoft® Word documents, with compareDocs automatically comparing 

the Word versions of the original and modified PDF documents.  The result of this comparison process 

is a working Word document, with changes marked up using Microsoft® Word’s Track Changes or 

Formatting. 

Efficiency through integration 

compareDocs can compare two (2) documents from multiple sources including your chosen document 

management system, quickly and efficiently, using industry standard ‘right-click menu option’ 

techniques and integrated application toolbar buttons where possible. 

NOTE:  Please refer to Supported integrations for a list of external applications with which 

compareDocs is compatible. 

Anything-to-anything document comparison 

compareDocs can compare any two (2) supported document types. 

PDF-to-PDF document comparison 

Any two (2) PDF documents can be compared to each other from any number of sources, with the 

comparison result being displayed as either a PDF or a Word document.  When compareDocs is 

installed with OCR Server/Desktop, the resulting Comparison Report can be displayed as a Microsoft® 

Word document, with changes marked up using Microsoft® Word’s Track Changes or Formatting. 
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Word-to-Word document comparison 

Any two (2) Microsoft® Word documents can be compared to each other from any number of sources, 

with the comparison result being displayed as a Word document.  Word comparisons can also be 

displayed as a PDF. 

PDF-to-Word OR Word-to-PDF document comparison 

With compareDocs, PDF documents can be compared directly to Microsoft® Word documents and vice 

versa, achieved using compareDocs’ PDF creation capabilities.  When comparing documents of two (2) 

different types, the comparison result will be displayed as a PDF.  When compareDocs is installed with 

OCR Server/Desktop, the resulting Comparison Report can be displayed as a Microsoft® Word 

document, with changes marked up using Microsoft® Word’s Track Changes or Formatting. 

Anything-to-anything document comparison 

With compareDocs, any text-based document can be compared directly to another, achieved using 

compareDocs’ PDF creation capabilities.  This means that any supported document types that can be 

converted to PDF using the compareDocs PDF printer can be compared, with the comparison result 

being displayed as a PDF.  When compareDocs is installed with OCR Server/Desktop, the resulting 

Comparison Report can be displayed as a Microsoft® Word document, with changes marked up using 

Microsoft® Word’s Track Changes or Formatting. 

Opening compareDocs 

compareDocs can be opened as a standalone application from Start > Program > DocsCorp > 

compareDocs.  compareDocs can also be accessed via integrations with various applications and 

document management systems.  Access to compareDocs from within external applications adopts 

industry-standard ‘right-click’ menu options, application ribbon and ‘drag and drop’ functionality.  This 

design approach enables the most efficient means of integration available, in a way that is completely 

familiar to users. 

For further information on integration between compareDocs and other applications, please refer to 

the chapters on: 

 Getting started with compareDocs; and 

 Document management system (DMS) integration. 

NOTE:  Please refer to Supported integrations for a list of external applications with which 

compareDocs is compatible. 
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compareDocs - User interface 

Main application window 

 

 

Menu options 

# Menu option Description 

1 

 

Cog > File menu Contains application controls (refer below): 
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# Menu option Description 

1.1 Cog >File > New 

comparison 

Opens a new Main window to allow for multiple comparisons 

to be performed independently of one another. 

1.2 Cog > File > Open original 

from… 

Allows browsing to the location of your original document for 

comparison. 

My Computer is the default option within this menu. 

If using a document management system (DMS), compareDocs 

will recognize presence of that DMS and automatically install 

the appropriate menu option to allow browsing of the DMS for 

the original document. 

For more information on DMS integration, including 

integrations currently available, please refer to Document 

management system (DMS) integration. 

1.3 Cog > File > Open modified 

from… 

Allows browsing to the location of your modified document for 

comparison. 

My Computer is the default option within this menu. 

If using a document management system (DMS), compareDocs 

will recognize presence of that DMS and automatically install 

the appropriate menu option to allow browsing of the DMS for 

the modified document. 

For more information on DMS integration, including 

integrations currently available, please refer to Document 

management system (DMS) integration. 

1.4 Cog > File > Restore Track 

Changes Default 

When using compareDocs with the Track Changes Report 

Types, compareDocs will apply your selected Rendering Set to 

markup differences between the documents compared. 

Selecting this option upon completion of your comparison will 

ensure that any changes made to your native Word Track 

Changes Options will be restored to their pre-compareDocs 

state.  

1.5 Cog > File > Save Track 

Changes Settings 
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# Menu option Description 

1.6 Cog > File > Exit Closes the active instance of compareDocs.      

2 

 

Cog > Settings menu Displays application Setting window, including Compare, 

Rendering and Output Settings. 

For a complete description of application Settings, please refer 

to Settings window. 

3 

 

Cog > About menu Contains application help, version and licensing information 

(refer below): 

For a complete description of About window, please refer to 

Cog > About. 

Functions > Compare Documents 

# Option Description 

4 Original document field | 

Most recently used (MRU) 

list 

An editable dropdown list displaying the document name and 

file type extension of the Original document being compared. 

The name of the Original document can manually entered into 

this field.  The name of the Original document can also be 

copied and pasted into the Modified field (and vice versa) to 

facilitate greater efficiency. 

This dropdown list contains a record of the 10 most recently 

used Original documents, with the most recently used 

document at the top of the list.  Documents in this list can be 

selected and compared again providing that their locations 
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# Option Description 

have not changed since previously being compared.  This 

functionality also applies to documents sourced from a DMS.   

NOTE: Information about the name and location of email 

attachments cannot be retained and therefore, previously 

compared email attachments are not displayed in the MRU list. 

This field is also a ‘drag and drop’ zone for any documents or 

attachments not located in your DMS, including email 

attachments.  Simply ‘click and drag’ a document from your File 

System, Windows Desktop or an email attachment onto this 

field to populate. 

5 Original document 

information icon 

Original document information icon which, when hovered over 

with the mouse, displays the following document attributes: 

 Name; 

 Title; 

 Author; 

 Date Created; 

 Last Modified; and 

 Size. 

When integrated with a DMS, clicking on this icon will open the 

document profile window from the DMS. 

6 Open Original document 

button 

When clicked, this button will display an Open window, 

allowing you to browse and locate the Original document from 

‘My Computer’ by default. 

When integrated with a DMS, clicking on this button will drop 

down a list of options, being ‘My Computer’ and the name of 

the DMS.  Clicking on the DMS name will display your DMS 

Open window. 

NOTE: If compareDocs is installed in a DMS integrated 

environment, users can change the default ‘Open From’ 

location from ‘My Computer’ to ‘DMS’.  This default can be 

changed via Cog > Compare settings. 
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# Option Description 

7 Swap button When clicked, the Swap button reverses the order of your 

Original and Modified documents by swapping the Original and 

Modified dropdown list options. 

8 Modified document field | 

Most recently used (MRU) 

list 

An editable dropdown list displaying the document name and 

file type extension of the Modified document being compared. 

The name of the Modified document can manually entered into 

this field.  The name of the Original document can also be 

copied and pasted into the Modified field (and vice versa) to 

facilitate greater efficiency. 

This dropdown list contains a record of the 10 most recently 

used Modified documents, with the most recently used 

document at the top of the list.  Documents in this list can be 

selected and compared again providing that their locations 

have not changed since previously being compared.  This 

functionality also applies to documents sourced from a DMS.   

NOTE: Information about the name and location of email 

attachments cannot be retained and therefore, previously 

compared email attachments are not displayed in the MRU list. 

This field is also a ‘drag and drop’ zone for any documents or 

attachments not located in your DMS, including email 

attachments.  Simply ‘click and drag’ a document from your File 

System, Windows Desktop or an email attachment onto this 

field to populate. 

9 Modified document 

information icon 

Modified document information icon which, when hovered 

over with the mouse, displays the following document 

attributes: 

 Name; 

 Title; 

 Author; 

 Date Created; 

 Last Modified; and 

 Size. 
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# Option Description 

When integrated with a DMS, clicking on this icon will open the 

Document Profile window from the DMS. 

10 Open Modified document 

button 

When clicked, this button will display an Open window, 

allowing you to browse and locate the Modified document 

from ‘My Computer’ by default. 

When integrated with a DMS, clicking on this button will drop 

down a list of options, being ‘My Computer’ and the name of 

the DMS.  Clicking on the DMS name will display your DMS 

Open window. 

NOTE: If compareDocs is installed in a DMS integrated 

environment, users can change the default ‘Open From’ 

location from ‘My Computer’ to ‘DMS’.  This default can be 

changed via Cog > Compare settings. 

Functions > Output Settings and Actions 

# Option Description 

11 Document Output > 

Word option 

This option specifies that the Comparison Report will be 

produced in Microsoft® Word format. 

When Word is the selected Document Output, the Report Type 

defaults to Consolidated report marked up with track changes . 

NOTE: This setting is available when comparing two (2) 

Microsoft® Word documents. Also available when comparing 

two (2) non Word document e.g. PDF, if “Allow PDF’s to be 

converted to Word and then compared” setting is checked 

under Cog > OCR 

12 Document Output > PDF 

option 

 

This option specifies that the Comparison Report will be 

produced in PDF format. 

When PDF is the selected Document Output, the Report Types 

defaults to Consolidated report marked up with annotations. 

NOTE: When either of the selected documents is not a Word 

document, Document Output defaults to PDF. 
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# Option Description 

13 When Document Output is Word: 

 

When Document Output is PDF: 

 

Report Type Report Types available change dynamically based on a 

combination of the source document types and the selection of 

either Word or PDF Document Output.  These options reflect 

the Comparison Report markups available when comparing 

Word-to-Word, PDF-to-PDF, Word-to-PDF, PDF-to-Word, or 

anything-to-anything. 

See below for explanations of the various combinations. 

13.1 Report Type > 

Consolidated report 

marked up with track 

changes 

Available when Word is the Document Output and the source 

documents are both Word documents. 

The outcome of this selection is a Word document containing 

all changes marked up using Microsoft® Word’s native Track 

Changes functionality.  The final format depends on the 

Document Output choice of Word or PDF.  

If Word, this allows you to begin accepting or rejecting changes 

immediately upon completion of the comparison using right 

mouse clicks. 

If PDF, this converts the Word comparison output back to PDF 

to ensure the presentation of the changes cannot be edited. 

Markup of the Word Comparison Report is based on Word 

Rendering Set options selected. 

13.2 Report Type > 

Consolidated report 

Available when Word is the Document Output and the source 

documents are both Word documents. 
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# Option Description 

marked up with 

formatting 

The outcome of this selection is a Word document containing 

all changes marked up using industry standard ‘redline’ 

formatting, being: 

 Red strikethrough for deletions; 

 Blue underlining for insertions. 

The consolidated, formatted Comparison Report does not allow 

accepting or rejecting of changes using Microsoft® Word’s 

native Track Changes functionality. 

Markup of the Word Comparison Report is based on Word 

Rendering Set options selected. 

13.3 Report Type > 

Consolidated report 

marked up with 

annotations 

Available when PDF is the Document Output and the source 

documents are either Word documents, PDF documents or any 

other compatible document type. Documents other than PDF 

are first converted to PDF before comparison. 

The outcome of this selection is a consolidated PDF document 

containing all changes marked up using PDF annotations. 

Markup of the PDF Comparison Report is based on PDF 

Rendering Set options selected. 

13.4 Report Type > Side-by-

side report marked up 

with annotations 

Available when PDF is the Document Output and the source 

documents are either Word documents, PDF documents or any 

other compatible document type. Documents other than PDF 

are first converted to PDF before comparison. 

The outcome of this selection is a side-by-side PDF document 

containing all changes marked up using PDF annotations. 

Markup of the PDF Comparison Report is based on PDF 

Rendering Set options selected. 

13.5 Report Type > 

Consolidated report 

marked up with track 

changes 

Available when PDF is the Document Output and the source 

documents are both Word documents. 

Also available when PDF is the Document Output and the 

source documents are non-Word e.g. PDF, if “Allow PDF’s to be 

converted to Word and then compared” setting is checked 

under Cog > OCR 
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The outcome of this selection is a PDF document containing all 

changes marked up using Microsoft® Word’s native Track 

Changes formatting. 

Markup of the PDF Comparison Report is based on Word 

Rendering Set options selected. 

13.6 Report Type > 

Consolidated report 

marked up with 

formatting 

Available when PDF is the Document Output and the source 

documents are both Word documents. 

Also available when PDF is the Document Output and the 

source documents are non-Word e.g. PDF, if “Allow PDF’s to be 

converted to Word and then compared” setting is checked 

under Cog > OCR 

The outcome of this selection is a consolidated PDF document 

containing all changes marked up using industry standard 

‘redline’ formatting, being: 

 Red strikethrough for deletions; 

 Blue underlining for insertions. 

Markup of the PDF Comparison Report is based on Word 

Rendering Set options selected. 

14 Report Type > Include 

Summary Report option 

This option produces a 1-page summary of statistical 

differences between the two (2) files compared. 

This Summary includes: 

 Path and file name of the Original and Modified documents 

compared; 

 A summary of the changes found; and 

 Statistical information about physical differences between 

the Original and Modified documents. 

Change Summary Reports are available for both Word and PDF 

comparisons. 

NOTE: Display and insertion of Change Summary Reports are 

determined by selections made in Cog > Output 
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# Option Description 

15 Report Type > Include 

Detail Report option 

This option produces a detailed report listing differences 

between the Original and Modified documents. 

When two (2) documents are compared, the Change Detail 

Report provides a cross-referenced listing of changes, 

facilitating a more efficient review of differences between the 

source Word documents. 

Change Detail Reports are available for both Word and PDF 

comparisons. 

NOTE: Display and insertion of Change Detail Reports are 

determined by selections made in Settings > Output > PDF or 

Settings > Output > Word. 

16 Report Type > Include 

Changes Only report 

option 

Available only for Word as the selected Document Output. 

The outcome of this selection is a report in PDF format, but 

based on the Word comparison report. It is limited to showing 

only pages with changes.  The Changes Only report can be 

saved or printed to any printer for review. 

NOTE:  The Changes Only report option cannot be used in 

conjunction with the Summary Report and Detail Report. 

17 Rendering Sets 

dropdown list 

A list of Rendering Set options available for markup of the 

selected comparison results. 

Rendering Sets can be managed via Cog > Rendering > Word or 

Cog > Rendering > PDF 

18 Compare button 

 

Compare button initiates a document comparison.  Upon initial 

selection of the Compare button, a dropdown list of actions is 

presented, including: 

 View As New Document – Initiates a comparison of the 

Original and Modified documents, and opens the 

Comparison Report as a new document in Microsoft® Word 

or your PDF reader; 

 Email… – Initiates a comparison of the Original and 

Modified documents, and opens a window allowing 

selection of the documents to be emailed (i.e. Comparison 

Result, Original and/or Modified Documents).  The Email 
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Documents window also allows entry of an email subject 

which will populate the Subject field within the email; 

 Save As… – Allows you to browse to a location in which to 

save the Comparison Report.  By default, this location is 

‘My Computer’; and 

 Print – Initiates a comparison of the Original and Modified 

documents.  Upon completion, the following message is 

displayed, requiring a choice of either print all pages or just 

those pages with changes: 

 

The Compare button is disabled until such time as both the 

Original and Modified documents are populated with valid 

documents. 

NOTE:  When integrated with a DMS, an additional option is 

automatically configured and appears underneath the Save As… 

option, titled Save Into [DMS]…, where [DMS] is the name of 

your document management system.  Clicking on Save Into 

[DMS]… will display your DMS Save window, allowing profiling 

of the Comparison Report within your DMS. 

19 Close button Closes the active instance of compareDocs. 

20 Edit  Opens the Rendering Set window in Settings for the currently 

selected Rendering set 
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Email Documents window 

 

# Option Description 

1 Subject field The default value for this field is the name of the Modified 

document and this value will be used to populate the Subject 

field in an email message.  This default value can be changed by 

the user and the new value will be used instead of the Modified 

document name.  

2 Select Attachments > 

[Comparison Result] 

checkbox 

Select this checkbox if you would like to attach the Comparison 

Result to the email being composed. 

NOTE:  If you require the name of the Comparison Result to be 

something other than the default, simply click on the 

Comparison Result and click again to make this field editable. 

3 Select Attachments > 

[Original Document] 

checkbox 

Select this checkbox if you would like to attach the Original 

Document to the email being composed. 

NOTE:  If you require the name of the Original Document to be 

something other than the default, simply click on the Original 

Document and click again to make this field editable. 

4 Select Attachments > 

[Modified Document] 

checkbox 

Select this checkbox if you would like to attach the Modified 

Document to the email being composed. 

NOTE:  If you require the name of the Modified Document to be 

something other than the default, simply click on the Modified 

Document and click again to make this field editable. 
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5 OK button When clicked, an email message will be generated, including 

the specified Subject and selected attachments.  Once the 

email message is generated, the Email Documents window is 

closed. 

6 Cancel button Cancels the Email creation process and closes the Email 

Documents window. 
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Selection window 

When more than two (2) documents are sent to compareDocs simultaneously (i.e. via multi-select > 

right-click in Windows Explorer or when multiple DMS documents or a DMS document with more than 

2 versions is selected), all documents are displayed in the Selection window.  The Selection window is 

a navigation mechanism for selecting which documents are sent to the Main application window, 

either new or existing, for comparison. 

If one (1) or more Main application windows are open, with documents loaded into the Original and 

Modified document fields, loading any further documents into compareDocs will display the added 

documents in the Selection window. 

 

# Option Description 

1 Document selection list The Document selection list lists all documents currently 

available for selection to be compared, including any versions 

of documents.  Document versions will be displayed in a tree-

like structure, sitting below the original version. 

2 Compare To option and 

dropdown list 

When one (1) document is selected (i.e. checked) from the 

Document selection list, with one (1) or more documents 

already present in the Main application window (as Original or 
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Modified documents), the Compare To option becomes 

available. 

When one (1) or more documents are present in any opened 

Main application window, the Compare To dropdown list allows 

selection of these already loaded documents for comparison to 

those presented in the Document selection list. 

3 New Comparison option When either one (1) or two (2) documents are selected (i.e. 

checked) from the Document selection list, the New 

Comparison option is available for selection.  Selection of this 

option and clicking the Next button will launch a new instance 

of the Main application window with the selected document(s) 

loaded in the Original and Modified document fields. 

4 Next button Enabled when acceptable choices have been made in the 

Selection window and progresses to the Main application 

window upon selection. 

5 Cancel button Closes the active instance of the Selection window and displays 

the Main application window. 
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Cog > Settings window 

Settings 

 

# Option Description 

1 Compare  Displays the compareDocs Compare Settings, which dictate 

comparison behavior, default settings and workflow, as 

opposed to markup behavior.  Compare Settings are available 

for both PDF and Word comparisons. 

2 Rendering Set - Word Displays the compareDocs Rendering Settings for Word.   

3 Rendering Set - PDF Displays the compareDocs Rendering Settings for PDF.   

4 Output  Displays the compareDocs Output Settings.  Output Settings are 

available for both PDF and Word comparisons. 

5 OCR  Displays the compareDocs OCR Server/Desktop integration 

Settings.   
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6 Language  Displays the compareDocs Language settings.  The chosen 

language is selected from a drop down menu.  

7 DMS [by Name] If DMS integration is detected display the compareDocs 

Document Management System (DMS) integration settings for 

the appropriate product. See section of DMS integrations 

Settings > Compare  

# Option Description 

8 General Settings  

9 Summary Report Header Allows insertion of a user-defined Summary Report Header 

onto the Change Summary Report. 

10 Save As Location When a comparison is performed and Save As is selected from 

the Compare dropdown button, the Save As Location specified 

in this field will become the default location for this action. 

11 Open Comparison Report 

after Saving 

When a Comparison Report is saved, either locally or into a 

document management system, these options determine if and 

how the Comparison Report is displayed upon completion of 

the save.  These options are: 

 Prompt Me to Open the Saved Comparison Report – asks 

you whether you would like to view the saved Comparison 

Report; 

 Always Open Comparison Report after Saving – opens the 

saved Comparison Report without prompting; and 

 Never Open Comparison Report after Saving – saves the 

Comparison Report without displaying the saved report. 

12 Display a copy of the PDF 

Comparison Report saved 

into Worksite  (ONLY 

AVAILABLE where installed 

with HP Worksite) 

This option is only available when HP Worksite DMS is 

detected. See also other DMS specific options under the 

Worksite tab in Settings. 
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13 Open From Location A dropdown menu allowing selection of a default ‘Open From 

Location’.  This selection will determine whether the [Open] 

button on the main application window will open from ‘My 

Computer’, a ‘DMS’ (Document Management System), or 

maintain default behavior with the selection of ‘None’. 

14 Auto select last 2 versions 

(ONLY AVAILABLE where 

installed with HP Worksite 

and eDocs DMS) 

When a document is loaded from the DMS into compareDocs if 

this option is set, the latest 2 versions of that document will 

automatically be loaded into the Original and Modified 

document fields.  

15 Close application after 

comparing 

A checkbox allowing for compareDocs to be automatically 

closed at the completion of each comparison. As compareDocs 

is often started from a DMS or right clicks on Windows Explorer 

this allows for the application to be closed without having to do 

it yourself. 

16 Save comparison into DMS 

(ONLY AVAILABLE where 

installed with Worldox 

DMS) 

(Not shown on the screen 

image above) 

When compareDocs is installed within a Worldox DMS 

environment, an additional Workflow Setting is enabled which 

dictates the silent Worldox integrated workflows.  There are 4 

options available for selection: 

 Let me choose  displays the Source Versions Available 

window allowing you to select against which compared 

document the Comparison Report will be saved; 

 Against the modified document only  bypasses the 

Source Versions Available window, automatically saving the 

Comparison Report against the modified Worldox 

document compared; 

 Against the original document only  bypasses the Source 

Versions Available window, automatically saving the 

Comparison Report against the original Worldox document 

compared; 

 Against both original and modified  bypasses the Source 

Versions Available window, automatically saving the 

Comparison Report against both the original and modified 

Worldox documents compared. 
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17 Word Compare Settings  

18 Word Compare > Character 

Level 

When selected, comparison of two (2) Word documents is 

performed at a character level.  For example, the following 

change may be indicated in the Comparison Report: 

 Original text: That cat has brown fur. 

 Modified text: Thatis cat has brownlack fur. 

If character level is not selected, then the modified text will be 

marked up at a word level and may be indicated as follows: 

 Modified text: ThatThis cat has brownblack fur. 

19 Word Compare > 

Headers/Footers 

When selected, Word documents containing changes to Header 

and Footer content will be marked up in the Comparison 

Report. 

20 Word Compare > 

Footnotes/Endnotes 

When selected, Word documents containing changes to 

Footnote and Endnote content will be marked up in the 

Comparison Report. 

21 Word Compare > List 

Numbers 

When selected, Word documents containing changes to List 

Numbers will be marked up in the Comparison Report. 

22 Word Compare > Tables When selected, Word documents containing changes to Table 

content will be marked up in the Comparison Report. 

23 Word Compare > Field 

Codes 

When selected, Word documents containing changes to Field 

Codes will be marked up in the Comparison Report. 

24 Word Compare > Text 

Boxes 

When selected, Word documents containing changes to Text 

Box content will be marked up in the Comparison Report. 

25 Word Compare > 

Comments 

When selected, Word documents containing comments and 

changes to Comments will be marked up in the Comparison 

Report. 

Comments are depicted in the report as part of the document 

text but highlighted in yellow.   
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26 Word Compare > Show 

Moves 

When selected and used in conjunction with the “Consolidated 

report marked up with formatting” Report Type, Word 

Comparison Reports will mark up text that has been moved 

from one location in the document to another, as opposed to 

moves being marked up as deletions from the source and 

insertions at the destination. 

NOTE:  Marking up of moves natively in Microsoft® Word is 

dependent on the version of Word being used and the Report 

Type selected, as described below. 

Consolidated report marked up with formatting – ALL 

Microsoft® Word versions: 

When selected, this setting will result in moved text being 

marked up in the “Consolidated report marked up with 

formatting” will display ‘moved from’ text as green, 

strikethrough text and as green, double-underlined text at the 

‘moved to’ location. 

Consolidated report marked up with track changes – 

Microsoft® Word 2007 or higher ONLY: 

When selected and used in conjunction with Word 2007 or 

higher or higher, the “Consolidated report marked up with 

track changes” will display ‘moved from’ text as green, 

strikethrough text and as green, double-underlined text at the 

‘moved to’ location. 

27 Word Compare > Flatten 

Field Codes 

When selected compareDocs will flatten all field codes prior to 

comparing content. This option is used to provide a comparison 

report that is a snapshot at a point in time. If not selected, the 

comparison report values can change due to operations of 

Word that will update field codes e.g. print, F9 etc. 

NOTE: NUMPAGE and PAGE field codes are not flattened as 

these elements need to reflect latest information in all cases 

28 Word Compare > Enable 

improved Track Changes 

output (LiveDocument) 

When selected compareDocs will produce track changes output 

with changes from the classic track change output. These 

differences are centered on list numbers, cross-reference field 

codes and tables 
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NOTE: Please refer to a separate document ‘LiveDocument 

Quick Reference Guide’ for how to work with results created by 

this option. 

29 PDF Compare Settings  

30 Fine Tuning > High The Fine Tuning setting determines the scope of markup which 

is applied to PDF Comparison Reports. 

A Fine Tuning setting of High will display changes to a word at a 

word level.  For example, the following change may be 

indicated in the Comparison Report: 

 Original text:  That cat has brown fur. It is angry; 

 Modified text: That cat has black fur. It is angry. 

 Fine Tuning > Medium A Fine Tuning setting of Medium will display changes to a word 

at a sentence level.  For example, the following change may be 

indicated in the Comparison Report: 

 Original text:  That cat has brown fur. It is angry; 

 Modified text: That cat has black fur. It is angry. 

 Fine Tuning > Low A Fine Tuning setting of Low will display changes to a word at a 

paragraph level.  For example, the following change may be 

indicated in the Comparison Report: 

 Original text:  That cat has brown fur. It is angry; 

 Modified text: That cat has black fur. It is angry. 

31 PDF Compare > Include all 

Worksheets 

When comparing two (2) Microsoft® Excel spreadsheets, 

selecting this setting will ensure that the entire Workbook (i.e. 

multiple Worksheets) is automatically converted to PDF prior to 

being compared. 

Conversely, deselecting this option will result in only the first 

Worksheet being converted to PDF prior to being compared. 

http://www.docscorp.net/downloads/InstallUserGuides/compareDocs/LiveDocument%20Quick%20Reference%20Guide.pdf
http://www.docscorp.net/downloads/InstallUserGuides/compareDocs/LiveDocument%20Quick%20Reference%20Guide.pdf
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32 PDF Compare  > Show 

Moves 

When selected, this option will enable the detection and 

marking up of moved content, or ‘Moves’, when comparing 

documents as PDFs. 
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Settings > Rendering > Word 

NOTE: compareDocs is provided with a suite of default Rendering Sets, known as Server-side 

Rendering Sets.  Server-side Rendering Sets are accordingly marked with “(Server)” following the 

Rendering Set name.  Server-side Rendering Sets cannot be removed, renamed or modified, but can 

be used as a template for new Local Rendering Sets, created and stored locally on your computer. 

 

 

# Option Description 

1 Rendering Set dropdown 

list 

A list of Rendering Set options available for markup of 

comparison results.  Default Rendering Sets available are: 

 New – when selected, enables a new local rendering set to 

be created.  The Track Changes fields (refer point 6 ) 

become available to create the new Rendering Set; 

 Standard (Server); 

 Standard with carets for deletes (Server); 

 Standard with bold for formatting (Server); and 
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 Standard with color blue for formatting (Server). 

2 New button The Track Changes (6) and Formatting (7) fields become 

available so the template can be amended to create a new local 

rendering set.   

To save the new Rendering Set, click on the Save As button. You 

will be prompted to provide a new name for this rendering set 

which will then be included on the Rendering Set dropdown list. 

3 Save As button Saves new Rendering Sets with a user-defined name upon 

creation via the New button, as well as copies existing 

Rendering Sets and saves them with a different user-defined 

name. 

4 Rename button Allows renaming of a user-defined Rendering Set. 

NOTE: Rename button is disabled for default Rendering Sets. 

5 Delete button Allows deletion of a user-defined Rendering Set. 

NOTE: Delete button is disabled for default Rendering Sets. 

6 Track Changes Enables track changes to be turned on and the format of the 

changes to be specified.   

NOTE: These options are disabled unless a Local User defined 

rendering set is being used. 

6.1 Enable Track Changes Select to turn Track Changes ON.  This then enables the format 

of the change types to be selected. 

6.2 Markup > Insertions Sets the format used to mark inserted text. 

6.3 Markup > Color Sets the color applied to insertions.   

6.4 Markup > Deletions Sets the format used to mark deleted text. 

6.5 Markup > Color Sets the color applied to deleted text. 

6.6 Markup > Moved From Sets the format used to mark text that has been move FROM 

elsewhere in the document.   
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Note:  Only available with Office 2007 or higher 

6.7 Markup > Color Sets the color applied to the ‘Moved From’ text. 

Note:  Only available with Office 2007 or higher 

6.8 Markup > Moved to Sets the format used to mark text that has been inserted 

(moved to) from elsewhere in the document. 

Note:  Only available with Office 2007 or higher 

6.9 Markup > Color Sets the color applied to the ‘Moved To’ text. 

Note:  Only available with Office 2007 or higher 

7 Format Enables the format of track changes to be turned on and the 

format of the changes to be specified.   

NOTE: These options are disabled unless a Local User defined 

rendering set is being used. 

7.1 Mark up > Enable 

Formatting 

Select to turn on tracking of format changes. 

7.2   

7.3 Mark up > Insertions Sets the format to be used to mark inserted format changes. 

7.4 Mark up > Deletions Sets the format to be used to mark deleted format changes. 

7.5 Mark up > Moved From Sets the format to indicate where format changes have moved 

from. 

7.6 Mark up > Moved Too Sets the format to indicate where format changes have moved 

to. 

7.7 Mark up > Color Sets the color applied to each mark up type. 

7.8 Mark up > Highlighting Sets the color to be used to highlight format fir each markup 

type 

7.9 Mark up > Bold Sets the mark ups to be displayed in bold. 
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Settings > Rendering > PDF 

NOTE: compareDocs is provided with a suite of default Rendering Sets, known as Server-side 

Rendering Sets.  Server-side Rendering Sets are accordingly marked with “(Server)” following the 

Rendering Set name.  Server-side Rendering Sets cannot be removed, renamed or modified, but can 

be used as a template for new Local Rendering Sets, created and stored locally on your computer. 

 

# Option Description 

1 Rendering Set dropdown 

list 

A list of Rendering Set options available for markup of 

comparison results.  Default Rendering Sets available are: 
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 New – when selected, New clears all settings and allows 

creation of a new Rendering Set; 

 Standard (Server); 

 Standard without underlining (Server); 

 Standard with punctuation (Server); 

 Standard with ignore case (Server). 

2 New button When selected, the New button clears all settings and allows 

creation of a new Rendering Set. 

To save the new Rendering Set, click on the Save As button. 

3 Save As button Saves new Rendering Sets with a user-defined name upon 

creation via the New button, as well as copies existing 

Rendering Sets and saves them with a different user-defined 

name. 

4 Rename button Allows renaming of a user-defined Rendering Set. 

NOTE: Rename button is disabled for default Rendering Sets. 

5 Delete button Allows deletion of a user-defined Rendering Set. 

NOTE: Delete button is disabled for default Rendering Sets. 

6 Consolidated > Insertions Markup 

 Highlight – mark insertions with highlighting 

 Underline – mark insertions with underlining 

 Strikeout – mark insertions with strikethrough 

Colors 

 Insert - Sets the color applied to insertions 

 Change – Sets the color applied to insert side of changes 

 Move – Sets the color applied to insert side of moves 

7 Consolidated > Deletions Markup  
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 Caret [^] – A single marker will indicate the point from 

where the text was deleted. 

Colors 

 Delete - Sets the color applied to deletions 

 Change - Sets the color applied to delete side of changes 

 Move - Sets the color applied to delete side of moves 

8 Processing > Ignore Case 

option 

The Ignore Case option determines whether changes in case 

will be marked up as a change in the Comparison Report. 

For example, if Ignore Case is selected, then the following 

change may be indicated in the Comparison Report: 

 Original text:  That cat has brown fur; 

 Modified text: That CAT has black fur. 

If Ignore Case is not selected, then the following change may be 

indicated: 

 Modified text: That CAT has black fur. 

9 Processing > Attach 

Punctuation option 

The Attach Punctuation option determines whether or not 

changes to a word are indicated by including any attached 

punctuation in the markup. 

For example, if Attach Punctuation is selected, then the 

following change may be indicated in the Comparison Report: 

 Original text:  That cat has brown fur; 

 Modified text: That cat has brown hair. 

If Attach Punctuation is not selected, then the following change 

may be indicated: 

 Modified text: That cat has brown hair. 

10 Side by Side > Show 

Modified on… 

Setting to decide if the Modified document in a side-by-side 

output is on the left side or the right side 

11 Side by Side > Insertions Markup 

 Highlight – mark insertions with highlighting 
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 Underline – mark insertions with underlining 

 Strikeout – mark insertions with strikethrough 

Colors 

 Insert - Sets the color applied to insertions 

 Change – Sets the color applied to insert side of changes 

 Move – Sets the color applied to insert side of moves 

12 Side by Side > Deletions In a side-by-side output the delete side markups are shown in 

text not in annotation marks, so more options are available for 

markup 

Markup 

 Highlight – mark deletions with highlighting 

 Underline – mark deletions with underlining 

 Strikeout – mark deletions with strikethrough 

Colors 

 Insert - Sets the color applied to deletions 

 Change – Sets the color applied to delete of changes 

 Move – Sets the color applied to delete side of moves 

13 Side by Side > Ignore Case 

option 

The Ignore Case option determines whether changes in case 

will be marked up as a change in the Comparison Report. 

For example, if Ignore Case is selected, then the following 

change may be indicated in the Comparison Report: 

 Original text:  That cat has brown fur; 

 Modified text: That CAT has black fur. 

If Ignore Case is not selected, then the following change may be 

indicated: 

 Modified text: That CAT has black fur. 

14 Side by Side > Attach 

Punctuation option 

The Attach Punctuation option determines whether or not 

changes to a word are indicated by including any attached 

punctuation in the markup. 
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For example, if Attach Punctuation is selected, then the 

following change may be indicated in the Comparison Report: 

 Original text:  That cat has brown fur; 

 Modified text: That cat has brown hair. 

If Attach Punctuation is not selected, then the following change 

may be indicated: 

 Modified text: That cat has brown hair. 



USER MANUAL                       Version 4.0       

Page 37 

Settings > Output 

# Option Description 

1 PDF tab Displays Output Settings for PDF comparisons. 

2 Word tab Displays Output Settings for Word comparisons. 
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Settings > Output > Word 

 

# Option Description 

1 Track Changes > Show 

Track Changes Toolbar 

option 

Displays the Microsoft® Word Track Changes Toolbar is opened 

upon presentation of a Word Comparison Report when 

selected. 

2 Track Changes > Show 

Reviewing Pane option 

Displays the Microsoft® Word Track Changes Reviewing Pane is 

opened upon presentation of a Word Comparison Report when 

selected. 

3 Track Changes > Show 

Track Changes Formatting 

 

4 

 

Track Changes > Author 

dropdown 

When comparing Microsoft® Word documents using the 

“Consolidated report marked up with track changes”, each 

Tracked Change can include a user-specified Author record. 

4.1 Track Changes > Author > 

compareDocs 

When selected, “compareDocs” will be inserted as the Author 

of any change detected and marked up. 

4.2 Track Changes > Author > 

Blank 

When selected, no Author details will be displayed (i.e. Author 

= Blank). 

4.3 Track Changes > Author > 

Current Name (User Name) 

When selected, the current Word User’s name will be inserted 

as the Author of any change detected and marked up.  Put 

differently, Author details will reflect the User Name of the 

person comparing the documents. 

4.4 Track Changes > Author > 

Change Numbers 

When selected, Change Numbers will be used to correlate 

differences when comparing two (2) Word documents.  Change 



USER MANUAL                          Version 4.0     

Page 39 

# Option Description 

Numbers are noted within Word’s ‘Track Changes Balloons’ and 

in the Reviewing Pane when Track Changes are used to mark up 

differences in the Comparison Report. 

NOTE:  If cross-referenced Change Numbers are desired to 

ensure that your Comparison Report correlates with differences 

listed in your Change Detail Report, please ensure that this 

option is selected. 

4.5 Track Changes > Author > 

Custom Text 

When selected, this option activates the Custom Text field, 

allowing users to define their own Author details. 

4.6 Track Changes > Author > 

Custom Text field 

When Custom Text is selected from the Author dropdown list, 

text entered in this field will be inserted as the Author of any 

change detected and marked up. 

5 Change Reports > Include 

Change Summary Report 

option 

Default setting for the inclusion of a Change Summary Report 

with Word Comparison Reports.  This option determines 

default behavior for the Include Change Summary Report 

options on the Main application window. 

Selecting this option will produce a Change Summary Report in 

Word format, applying positioning of the report based on 

selections made in the Include Change Summary Report 

dropdown list. 

6 Change Reports > Include 

Change Summary Report 

dropdown list 

Default setting for the positioning of a Change Summary Report 

with Word Comparison Reports.  This option determines 

default behavior for the Include Change Summary Report 

options on the Main application window. 

Options available for selection are: 

 Display as a Separate Report; 

 Append to Beginning of Comparison Report; and 

 Append to End of Comparison Report. 

7 Change Reports > Include 

Change Detail Report 

option 

Default setting for the inclusion of a Change Detail Report with 

Word Comparison Reports.  This option determines default 

behavior for the Include Change Detail Report options on the 

Main application window. 
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Selecting this option will produce a Change Detail Report in PDF 

format, applying positioning of the report based on selections 

made in the Include Change Detail Report dropdown list. 

NOTE: It is important to note that a Word Change Detail Report 

is produced in PDF format. 

8 Change Reports > Include 

Change Detail Report 

dropdown list 

Default setting for the positioning of a Change Detail Report 

with Word Comparison Reports.  This option determines 

default behavior for the Include Change Detail Report options 

on the Main application window. 

Options available for selection are: 

 Display as a Separate Report. 

NOTE: It is important to note that a Word Change Detail Report 

is produced in PDF format. 

9 

 

Save Options > Save files in 

this format 

This option determines the document file format of Word 

Comparison Reports when saved from compareDocs. 

9.1 Save Options > Automatic – 

same as modified 

Selecting Automatic – same as modified saves the Comparison 

Report in the same document format as the Modified 

document being compared.  For example, if the Original 

document being compared is a *.DOC file and the Modified 

document is a *.DOCX, then the Comparison Report produced 

will be a *.DOCX. 

9.2 Save Options > Word 

Document 97 – 2003 

(*.doc) 

Selecting Word Document 97 – 2003 (*.doc) dictates that 

regardless of the file format of Word documents being 

compared, the Comparison Report will be saved in *.DOC 

format. 

9.3 Save Options > Word 

Document 2007 or higher 

(*.docx) 

Selecting Word Document 2007 or higher (*.docx) dictates that 

regardless of the file format of Word documents being 
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compared, the Comparison Report will be saved in *.DOCX 

format as 2007 or higher or higher format. 

10.1 Document View > Print 

View 

Displays the Word Comparison Report in Print View when Word 

is the specified Document Output. 

TIP: Print View is most commonly used to view text, graphics, 

headers/footers, section/page breaks, and other document 

formatting elements as they will be positioned on the printed 

page. 

10.2 Document View > Normal 

View 

Displays the Word Comparison Report in Normal View when 

Word is the specified Document Output. 

TIP: Normal View is most commonly used when typing, editing 

and formatting text within a document. 

11 General > Update 

Automatic Links at Open 

 

This option controls your Microsoft® Word application settings 

with respect to Automatic Links (Microsoft® Word > Tools > 

Options > General). 

Select this option if the Word documents being compared 

contain links to external documents to update these links 

automatically prior to the comparison being performed. 

Settings > Output > PDF 

# Option Description 

12 PDF Processing > Compare 

Data in Sequence 

By default, PDF files are processed in normal order (i.e. order of 

creation).  However, certain files may contain data that is not in 

sequence.  Using the Compare Data in Sequence option allows 

PDF files to be processed in a top down, left-to-right order, as 

viewed in Adobe Reader. 

13 PDF Annotations > Print 

Annotations 

This option prints the contents of all Annotations when the 

Comparison Report is printed. 

14 PDF Annotations > Hide 

Annotations 

This option hides Annotations used to display details of changes 

within a PDF Comparison Report when hovered over. 
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NOTE: This option has been implemented to work around a 

known JavaScript issue with Adobe Reader 8.0.  If you are 

running this version of Adobe Reader, please select this option. 

15 Unicode Characters > Show 

Unicode Differences 

When comparing PDF documents, certain characters may 

appear to be the same visually, but actually contain different 

Unicode characters. 

Selecting this option will display the Unicode difference within 

the comments and annotation of the PDF change. 

16 Change Reports > Include 

Change Summary Report 

option 

Default setting for the inclusion of a Change Summary Report 

with PDF Comparison Reports. 

NOTE: This option is mandatory for PDF comparisons and 

accordingly, cannot be deselected. 

17 Change Reports > Include 

Change Summary Report 

dropdown list 

Default setting for the positioning of a Change Summary Report 

with PDF Comparison Reports. 

NOTE: This option is mandatory for PDF comparisons and will 

always append the Change Summary Report to the beginning of 

the PDF Comparison Report. 

18 Change Reports > Include 

Change Detail Report 

option 

Default setting for the inclusion of a Change Detail Report with 

PDF Comparison Reports.  This option determines default 

behavior for the Include Change Detail Report options on the 

Main application window. 

Selecting this option will produce a Change Detail Report in PDF 

format, applying positioning of the report based on selections 

made in the Include Change Detail Report dropdown list. 

19 Change Reports > Include 

Change Detail Report 

dropdown list 

Default setting for the positioning of a Change Detail Report 

with PDF Comparison Reports.  This option determines default 

behavior for the Include Change Detail Report options on the 

Main application window. 

Options available for selection are: 

 Display as a Separate Report; 

 Append to Beginning of Comparison Report; and 
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 Append to End of Comparison Report. 

Settings > OCR 

 

# Option Description 

1 OCR Service Provider Allows entry of the OCR Server/Desktop Service Provider 

location.  This is a mandatory field if the corresponding 

checkbox is selected. 

Once the new OCR address has been entered press the ‘Refresh 

OCR’ button to enable and save the new configuration. 

This process is also run automatically by compareDocs every 24 

hours. 

NOTE:  Please ensure that OCR Server/Desktop is installed 

before activating this setting.  If OCR Server/Desktop is not 
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installed, then compareDocs will not be able to complete the 

conversion or comparison. 

2 OCR Provider > Display OCR 

Languages 

When selected, during comparison of documents that require 

OCR, the user will be presented with a list of languages being 

applied to the OCR process and the ability to add more. 

3 OCR Provider > Preserve 

image resolution and 

compression 

When selected, this option will ensure that the documents 

being sent to OCR Server are returned using the same 

resolution and compression rates. 

 This option also enables the selection of text orientation. 

4 Compare PDF as Word 

Documents > Allow PDF’s 

to be converted to Word 

and then compared 

Enables PDF documents to be automatically converted and 

compared as Word documents using OCR Server/Desktop.  

Once converted from PDF to Word, the documents are silently 

returned from OCR Server/Desktop and seamlessly compared 

as Word documents, using either Track Changes or Formatting 

to mark up differences. 

Once this setting is enabled, PDF documents can be converted 

and compared as Word documents by selecting the Word 

Document Output option from the compareDocs main 

application window. 

5 Compare PDF as Word 

Documents > Comparing 

PDF to Word – convert 

Word document to PDF 

first 

Only available when Enable PDF documents to be compared in 

Word format is selected. 

This checkbox dictates that when comparing a PDF document 

to a Word document directly, the Word document is first 

converted to PDF using pdfDocs (if installed), then both PDF 

documents are converted back to Word via OCR Server (if 

installed) and compared as native Word documents. 

This workflow facilitates the best possible result for comparison 

of Word to PDF and vice versa, as it ensures a common format 

for comparison. 
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Settings > Language 

 

 

# Option Description 

1 Language Options Displays the compareDocs Language settings.  The chosen 

language is selected from a drop down menu.  

The settings screen must be saved and exited for the selected 

language to take effect. 

Languages available include: 

 English (Default language) 

 English (US) 

 French 

 German 

 Korean 

 Norwegian 
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Cog > About 

 

1 License information compareDocs requires a valid license key in order 

to perform document comparisons.  License details 

are entered and stored in the License window. 

Set License button opens the license screen for 

review or entry of a valid license key. Simply enter 

the Name (e.g. name of organization) and Key into 

the License window, clicking [OK] when complete. 

The license Details (including Expiry date, Seats 

and License Type) are configured automatically 

upon entry of the Name, Key and clicking [OK]. 
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Changing of the license key details may be disabled 

if your Administrator has licensed compareDocs via 

the registry. 

2 File Information Displays information about the compareDocs 

product, including: 

 Program File location; 

 Configuration File location; 

 Log File location; 

3 Get Help User manual provides a web link to this manual for 

reading online or to save locally. The manual is in 

PDF format 

Log a support call provides a web link to our 

Support page on DocsCorp website. Your Support 

call can be logged here 

4 Log Management Open log folders will open the location, in 

Windows Explorer, of the compareDocs log 

folder(s) 

Zip and save logs will allow you to create a single 

file (as ZIP format) of all the logs for 

troubleshooting. A save dialog will be presented so 

you can save to any folder locally or on the 

network. 

5 Settings Update button will confirm latest license details 

are loaded and will look for newer versions of the 

MSI that have been placed in your Installer 

location for compareDocs. See Release notes guide 

for information on upgrades. 

6 Notices View License Agreement opens a PDF with the End 

User License agreement for compareDocs 

View Legal Notices opens a PDF with compareDocs 

Copyright and Acknowledgment notices 

7 Version information  The version of the software is shown in the bottom 

left of this 
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Comparison reports 

PDF Comparison Reports marked up with annotations 

PDF Comparison Reports marked up with annotations are displayed in Adobe Reader, with 

annotations inserted to signify changes and display details about those changes. 

The format of the annotations is controlled by the Rendering Sets for PDF. 

The examples below show the ‘Standard’ Rendering set 

# Formatting Description 

1 

 

Blue annotations represent changed text in PDF Comparison 

Reports. 

In this example, a change is also underlined, with vertical line 

[|] delimiters at the beginning and end of the change. 

NOTE: Underlining and Delimiter settings can be changed in 

PDF Rendering Settings. 

When hovering over the blue annotation icon, a tool tip is 

displayed, presenting the change details (e.g. Changed From 

‘tht’ To ‘that’) and the corresponding change number (e.g. #33). 

Changed text references are displayed in the Bookmarks Pane 

(see below).  These bookmarks can be used to assist with 

change navigation and review. 
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2 

 

Green annotations represent inserted text in PDF Comparison 

Reports. 

In this example, inserted text is also underlined, with caret [^] 

delimiters at the beginning and end of the change. 

NOTE: Underlining and Delimiter settings can be changed in 

PDF Rendering Settings. 

When hovering over the green annotation icon, a tool tip is 

displayed, presenting the inserted text details (e.g. Inserted 

‘and Affiliate …’) and the corresponding change number (e.g. 

#32). 

Inserted text references are displayed in the Bookmarks Pane 

(see below).  These bookmarks can be used to assist with 

change navigation and review. 

 

3 

 

Red annotations represent deleted text in PDF Comparison 

Reports. 

In this example, deleted text is represented with a caret [^] 

delimiter in the place of the deleted text. 

NOTE: Underlining and Delimiter settings can be changed in 

PDF Rendering Settings. 

When hovering over the red annotation icon, a tool tip is 

displayed presenting the deleted text details (e.g. Deleted ‘(a)’) 

and the corresponding change number (e.g. #110). 
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Deleted text references are displayed in the Bookmarks Pane 

(see Changed text above).  These bookmarks can be used to 

assist with change navigation and review. 

 

4 

 

Black annotations represent moved text in PDF Comparison 

Reports. 

In this example, deleted text is represented with black 

underlining and vertical line [|] delimiters at the beginning and 

end of the change. 

NOTE: Underlining and Delimiter settings can be changed in 

PDF Rendering Settings. 

When hovering over the black annotation icon, a tool tip is 

displayed, presenting the moved text details (e.g. Moved 

‘stamped on …’) and the corresponding change number (e.g. 

#442). 

Moved text references are displayed in the Bookmarks Pane 

(see Changed text above).  These bookmarks can be used to 

assist with change navigation and review. 
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Word Consolidated report marked up with track changes 

Word Comparison Reports marked up with track changes are displayed in Microsoft® Word, with all 

changes represented using Rendering Sets based on Microsoft® Word’s Track Changes feature.  The 

Word Comparison Reports are formatted based on your Rendering Set in compareDocs. 

Below is an extract from a Word Consolidated report marked up with track changes: 

 

NOTE:  When a Rendering Set is selected for use by compareDocs, all subsequent Word comparisons 

will apply that same Rendering Set to future comparisons or uses of Microsoft® Word’s Track Changes 

feature until such time as either the Rendering Set is changed from within compareDocs or the Track 

Changes Options are changed directly from within Microsoft® Word.  Please refer to Microsoft® 

Word’s Track Changes Options for a complete listing of formatting options available. 

Important note for Microsoft® Word 2007 or above users 

Users of Microsoft® Word 2007 or higher now have the ability to track moved text in Word 

Consolidated reports marked up with track changes.  Moved text is displayed in Word Comparison 

Reports based on Microsoft® Word Track Changes Options as follows: 

 Green double-underlining for ‘moved-to’ text locations; 

 Green double-strikethrough for ‘moved-from’ text locations. 
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Word Consolidated report marked up with formatting 

Word Comparison Reports marked up with formatting are displayed in Microsoft® Word, with all 

changes represented using the following industry-standard ‘redline’ options: 

 Red strikethrough for deletions; 

 Blue underlining for insertions; 

 Green double-underlining for ‘moved-to’ text locations; 

 Green strikethrough for ‘moved-from’ text locations. 

Below is an extract from a Word Consolidated report marked up with formatting: 
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Change summary reports 

Change Summary Reports are 1-page summaries of statistical differences between the two (2) files 

compared, as well as listing all settings and options applied on comparison. 

Change Summary Reports are available for both Word and PDF comparisons. 

NOTE:  Display and insertion of Change Summary Reports are determined by selections made in 

Settings > Output > PDF or Settings > Output > Word. 

Below is an example of a Change Summary Report for Word, as produced by compareDocs upon 

completion of a comparison: 
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Change detail reports 

Change Detail Reports provide a detailed listing of differences between the Original and Modified 

documents. 

When two (2) documents are compared, the Change Detail Report provides a cross-referenced listing 

of changes, facilitating a more efficient review of differences between the source Word documents. 

Change Detail Reports are available for both Word and PDF comparisons. 

NOTE: Display and insertion of Change Detail Reports are determined by selections made in Settings > 

Output > PDF or Settings > Output > Word. 

Below is an extract from the Change Detail Report resulting from a Word Consolidated report marked 

up with track changes: 

 

Changes only reports 

Changes Only Reports provide a document containing only those pages from the Comparison Report 

containing differences.  This report is printed to the compareDocs PDF printer, with the resulting 

output always being a PDF.  For example, if a comparison resulted in changes to pages 1-3 of 5, then 

the resultant Changes Only Report will contain 3 pages in total, being pages 1, 2 and 3. 

NOTE:  Change Only Reports are only available when comparing 2 Microsoft Word documents, and are 

not available for selection in conjunction with the Change Summary and Change Detail Reports. 
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Getting started with compareDocs 

Using compareDocs from Windows 

Right-click function 

Option Description 

 

Windows Desktop / File 

System > Right-click >  Send 

to > compareDocs 

Right-clicking a compatible document on the Windows Desktop or 

from the File System (e.g. Windows Explorer) and selecting the Send to 

> compareDocs option will load that document into compareDocs, 

ready for comparison to another selected document. 

Right-clicking on multiple documents (e.g. [CTRL] + [Mouse click] on 

multiple documents) and selecting the compareDocs option will load 

all selected documents into the compareDocs Main application 

window directly, or into the compareDocs Selection window, 

depending on the number of documents selected. 
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Drag & Drop function 

Option Description 

             

 

compareDocs > Drag and 

drop zone 

Compatible document types can be clicked and dragged from the 

Widows Desktop or File System, and dropped directly onto the Original 

and Modified document fields in compareDocs. 

This area, consisting of the Original and Modified document fields, is 

referred to as the drag and drop zone. 

Using compareDocs from Microsoft® Word 

Buttons 

Option Description 

 

Microsoft® Word > 

DocsCorp Ribbon  > 

compareDocs ribbon Group 

compareDocs installs a Ribbon into Microsoft® Word to allow greater 

efficiency through workflow automation directly from with Microsoft® 

Word. 

Microsoft® Word > 

DocsCorp Ribbon > Launch 

in compareDocs button 

Clicking the Launch in compareDocs button will load the document 

currently opened into compareDocs, ready for comparison to another 

selected document. 

Microsoft® Word > 

DocsCorp Ribbon > email 

comparison button 

Clicking the email comparison button will open the Email Documents 

window allowing the comparison report and/or copies of the original 

and modified documents to be attached to email.  
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Option Description 

Microsoft® Word > 

DocsCorp Ribbon > Save 

Into DMS button 

Clicking the Save Into DMS button will allow the Comparison Reported 

to be saved back into the DMS. 

NOTE:  This button will only perform a Save Into DMS where one or 

both of the documents compared were sourced from with the DMS. 

Microsoft® Word > 

DocsCorp Ribbon > Print 

Comparison Report to PDF 

button 

Clicking the Print Comparison Report to PDF button will print the entire 

Comparison Report, including markup, to the compareDocs PDF 

printer. 

Microsoft® Word > 

DocsCorp Ribbon > Print 

Pages with Changes to PDF 

button 

Clicking the Print Pages with Changes to PDF button in the Microsoft® 

Word toolbar will print only those pages in the Comparison Report 

with changes, including markup, to the compareDocs PDF printer. 

  Drop down options 
>Opens compareDocs  

Opens compareDocs. This button opens the application. It does not 

attempt to load any documents 

>Prepare for Accept Changes 

This button ensures that a ‘track changes’ comparison report can be 

completely reverted to the modified document if ‘Accept All Revisions’ 

is selected in Word. More specifically it undoes the markup of any list 

number insertions. 

>Restore Track Change default 

Restores the track change configuration in Word that was set before 

compareDocs had been executed. Due to render set choices made by a 

user, compareDocs will change the track changes settings in Word to 

produce the desired report. This button restores those settings to their 

original state before compareDocs was run. To be used in conjunction 

with ‘save track changes’ 

>Save Track Changes 

Marks the current track change configuration as the original 

configuration. Use this setting if you want compareDocs to restore 

Words track change configuration to be current configuration being 

used. 
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Using compareDocs from Microsoft® Outlook 

Drag & Drop function 

 

Using compareDocs from pdfDocs 

Button 

Option Description 

  

pdfDocs > Review ribbon > 

Compare button 

When compareDocs is installed onto a workstation with pdfDocs 

installed, the Compare button on the pdfDocs Review ribbon is 

enabled when one or more documents in the pdfDocs are selected (i.e. 

checked). 

Clicking the Compare button will load all selected documents into the 

compareDocs Main application window directly, or into the 

compareDocs Selection window, depending on the number of 

documents selected. 

Option Description 

    

compareDocs > Drag and 

drop zone 

Attachments of a compatible document type can be clicked and 

dragged from Microsoft® Outlook emails, and dropped directly onto 

the Original and Modified document fields in compareDocs. 

This area, consisting of the Original and Modified document fields, is 

referred to as the drag and drop zone. 
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Option Description 

The Compare button is disabled when either compareDocs is not 

installed or there are no documents are selected inside the pdfDocs 

Organizer. 

NOTE: When comparing documents directly from within pdfDocs, 

please ensure that Security is set to (None) and that Watermarks are 

turned off. 

Right-click function 

Option Description 

 

pdfDocs > Right-click > 

Compare 

When compareDocs is installed onto a workstation with pdfDocs 

installed, a right-click > Compare option is enabled. 

Right-clicking on a compatible document type in the pdfDocs Organizer 

and selecting the Compare option will load that document into 

compareDocs, ready for comparison. 
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Document management system (DMS) integration 

Using compareDocs with eDocs DM 

compareDocs > Settings > eDocs DM 

 Description 

 

Attachments 

If comparison reports are to be saved into eDocs as an ‘attachment’ to an existing profile it is 

common to want the attachment label to be something that identifies the document type of the 
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 Description 

attachment. Common options are PDF and DOC. By default an attachment is not able to be updated 

by saving a new document with the same label. This option will allow that to occur. 

Version / Subversion 

Option to apply automatic version commenting on saving to DMS. If option is selected the text in 

the Version and SubVersion comments will be used. 

 

compareDocs > Open > eDocs DM 

Description 

 

When integrated with eDocs DM, documents stored in the DMS can be selected directly from within 

compareDocs.  To access documents directly from eDocs DM, select Open > eDocs DM to launch the 

eDocs DM > Quick Retrieve window, allowing searching of eDocs DM and selection of a document to 

compare. 

When the documents being compared are sourced from DMS, then the naming convention applied is 

[DocID] [DocVersion] Document name.ext 

e.g. 

[#4877954][v4] Modified document.doc 
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compareDocs > Compare > Save Into eDocs 

Description 

 

When integrated with eDocs DM DMS, document comparison results can be saved directly back into 

the DMS directly from within compareDocs.  To save a Comparison Report back into eDocs DM DMS, 

select the documents for comparison (i.e. Original and Modified), then select Compare > Save Into 

eDocs DM. 

When Compare > Save Into eDocs DM is selected, compareDocs compares the selected documents 

‘silently’ (i.e. without displaying the Comparison Report).  Upon successful completion of the 

comparison, a Save As Options window is displayed presenting up to five (5) options to save the 

Comparison Report as a new document, a new version or sub-version of an existing document, a 

related document, or an attachment to an existing document. 

Selecting any of these options will launch the eDocs DM > Quick Retrieve window, allowing searching 

of eDocs DM DMS and selection of a document location.  Once a location has been specified, the 

eDocs DM > Source Versions Available window is displayed allowing profiling of the Comparison 

Report before saving. 
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eDocs DM DM > Right-click function 

Description 

 

When compareDocs is installed alongside eDocs DM DM5 or DM6, integration between the eDocs 

DM and compareDocs is automatically configured.  The result of this integration within eDocs DM is 

the insertion of a new right-click menu option to Open with compareDocs. 

When one (1) or more documents are selected from within eDocs DM, right-click > Open with 

compareDocs will send the selected documents to compareDocs (Main application window or 

Selection window) for comparison.  If the selected documents have multiple versions, then the 

Selection window will be presented, requiring that the appropriate documents and versions be 

selected prior to loading into the Main application window. 

When the documents being compared are sourced from DMS, then the naming convention applied is 

[DocID] [DocVersion] Document name.ext 

e.g. 

[#4877954][v4] Modified document.doc 



USER MANUAL                          Version 4.0     

Page 64 

Using compareDocs with HP Worksite DMS 

compareDocs > Edit > Settings > WorkSite 

Description 

 

When compareDocs is installed alongside HP Worksite, integration between the WorkSite DMS and 

compareDocs is automatically configured. 

In addition, where multiple DMS servers exist, compareDocs can store connection and authentication 

details for the various DMS servers. 

In order to establish an authenticated connection between compareDocs and the HP Worksite DMS, 

Login Settings can be stored in compareDocs, under Edit > Settings > WorkSite. 

If more than one (1) WorkSite DMS server exists, the Add button can be selected to allow entry of 

other DMS server details on a one-by-one basis. 

Alternatively, to retrieve details of all registered WorkSite servers, simply click on Update Servers.  

Upon clicking Update Servers, compareDocs will obtain and store all registered WorkSite server 

details. 



USER MANUAL                          Version 4.0     

Page 65 

Description 

NOTE: Please note that passwords will be required to be entered manually as these details are not 

retrieved from WorkSite. 

Upon completion of entering the relevant details, simply click on the Save button to commit these 

details to compareDocs. 

Once an authenticated connection exists between compareDocs and the HP Worksite DMS, future 

connections will not require a user name and password for logging into WorkSite from within 

compareDocs. 

TIP: If using Trusted Login method to access the HP Worksite DMS, please ensure that the Use 

Trusted Login setting is selected. 

Conversely, if Trusted Login method is not used to access the HP Worksite DMS, please ensure that 

this setting is not selected. 

If conflicting Login method settings are present, integration between compareDocs and HP Worksite 

may be problematic. 

compareDocs > Open > HP Worksite 

Description 

 

When integrated with HP Worksite DMS, documents stored in the DMS can be selected directly from 

within compareDocs.  To access documents directly from HP Worksite, select Open > Interwoven 

WorkSite to launch the WorkSite > Open window, allowing searching of HP Worksite DMS and 

selection of a document to compare. 

When the documents being compared are sourced from DMS, then the naming convention applied is 

[DocID] [DocVersion] Document name.ext 

e.g. 

[#4877954][v4] Modified document.doc 
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compareDocs > Compare > Save Into HP Worksite 

Description 

 

When integrated with HP Worksite DMS, document comparison results can be saved directly back 

into the DMS directly from within compareDocs.  To save a Comparison Report back into HP Worksite 

DMS, select the documents for comparison (i.e. Original and Modified), then select Compare > Save 

Into Interwoven WorkSite. 

When Save Into Interwoven WorkSite is selected, compareDocs compares the selected documents 

‘silently’ (i.e. without displaying the Comparison Report).  Upon successful completion of the 

comparison, a Save As Options window is displayed presenting three (3) options to save the 

Comparison Report as a new document, a new version of an existing document, or a related 

document. 

Selecting any of these options will launch the WorkSite > Open window, allowing searching of HP 

Worksite DMS and selection of a document location.  Once a location has been specified, the 

WorkSite > Save As window is displayed allowing profiling of the Comparison Report before saving. 
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HP Worksite DM > Right-click function 

Description 

 

The result of integration between compareDocs and WorkSite is the insertion of a new right-click 

menu option within WorkSite, being right click Integration > Send To compareDocs. 

When one (1) or more documents are selected from within WorkSite, right-click > Send to 

compareDocs will send the selected documents to compareDocs (Main application window or 

Selection window) for comparison.  If the selected documents have multiple versions, then the 

Selection window will be presented, requiring that the appropriate documents and versions be 

selected prior to loading into the Main application window. 

When the documents being compared are sourced from DMS, then the naming convention applied is 

[DocID] [DocVersion] Document name.ext 

e.g. 

[#4877954][v4] Modified document.doc 
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Using compareDocs with Worldox® DMS 

compareDocs > Open > Worldox® 

Description 

 

When integrated with Worldox® DMS, documents stored in the DMS can be selected directly from 

within compareDocs.  To access documents directly from Worldox®, select Open > Worldox to launch 

the Worldox > Open window, allowing searching of Worldox® DMS and selection of a document to 

compare. 

When the documents being compared are sourced from DMS, then the naming convention applied is 

[DocID] [DocVersion] Document name.ext 

e.g. 

[#4877954][v4] Modified document.doc 

compareDocs > Compare > Save Into Worldox® 

Description 

                                         

When integrated with Worldox® DMS, document comparisons results can be saved directly back into 

the DMS directly from within compareDocs.  To save a Comparison Report back into Worldox® DMS, 

select the documents for comparison (i.e. Original and Modified), then select Compare > Save Into 

Worldox. 

When Save Into Worldox is selected, compareDocs compares the selected documents ‘silently’ (i.e. 

without displaying the Comparison Report).  Upon successful completion of the comparison, a Save 
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Description 

As Options window is displayed presenting two (2) options to save the Comparison Report as a new 

document or a related document. 

Selecting either of these options will launch the Worldox > Select Profile Group window, allowing 

selection of a document location / Profile Group.  Once a location has been specified, the Worldox > 

File Save As window is displayed allowing profiling of the Comparison Report before saving. 

When saving a Comparison Report as a new version of a document in Worldox that already has Sub-

versions, then the Version Selector Form is displayed, offering both the next available version and 

sub-version as documents to which the Comparison Report can be saved against. 

Worldox® DM > Compare with compareDocs > Right-click function & Worldox 

File Menu 

Description 
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Description 

 

The result of integration between compareDocs and Worldox is the insertion of a right-click menu 

option within Worldox, named “Compare with compareDocs”.  In addition to this being added as a 

right-click menu, a Worldox File Menu of the same name is also inserted.  Selecting either of these 

options will display a 2nd level of options. 

When one (1) or more documents are selected from within Worldox, right-click > Compare with 

compareDocs > [Chosen action] will silently compare the documents, performing the action selection 

from the 2nd level menu, namely: 

 Email Comparison Report – compareDocs will silently compare the 2 documents selected from 

Worldox, displaying the Email Documents window upon completion; 

 Load Into compareDocs – the selected document(s) will be loaded into the compareDocs 

application for user-driven comparison, including the selection of settings to be used for the 

document comparison; 

 Save as New Document; 

o compareDocs will silently compare the 2 documents selected from Worldox, displaying 

the Worldox Profile window for direct profiling of the Comparison Report; 

 Save as New Version; 

o compareDocs will silently compare the 2 documents selected from Worldox, 

automatically saving the Comparison Report into Worldox as a new version of either the 

modified, the original or both documents, depending on the Workflow Settings selected; 

 Save as Related Document; 

o compareDocs will silently compare the 2 documents selected from Worldox, 

automatically saving the Comparison Report into Worldox as a related document of 

either the modified, the original or both documents depending on the Workflow Settings 

selected; 

 Save to My Computer; 
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Description 

o compareDocs will silently compare the 2 documents selected from Worldox, displaying a 

local Browse window to allow navigation to an appropriate location; 

 View Comparison Report; 

o compareDocs will silently compare the 2 documents selected from Worldox, displaying 

the resulting Comparison Report in either Microsoft® Word or Adobe® Reader. 

Worldox® DM > Compare Files function 

Description 

 

Another result of integration between compareDocs and Worldox is the ability to use the native 

Worldox Compare Files feature to load documents into compareDocs, whilst using compareDocs to 

compare the files. 

When one (1) or more documents are selected from within Worldox, clicking on the Compare Files 

button, or alternatively selecting Compare Files from the Worldox right-click menu, will send the 

selected documents to compareDocs (Main application window or Selection window) for comparison 

via the native Worldox Compare Files window.  Once inside of compareDocs, the documents can be 

compared. 
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Description 
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Using compareDocs with netdocuments® DMS 

netdocuments® DMS > Mark/Launch function 

Description 

 

The result of integration between compareDocs and netdocuments is the availability of compareDocs 

as an option when using the Mark/Launch feature upon selection of the source documents to be 

compared. 

Once Mark/Launch is selected, selecting compareDocs from this window will offer Import and View 

as selectable options. 
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Description 

 

Selecting Import will perform a silent comparison of the source documents and allow the 

Comparison Report to be imported back into netdocuments as an attachment to the modified source 

document. 

Selecting View will open compareDocs and allow a comparison to be performed without importing 

back into netdocuments. 
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Technical information & troubleshooting 

System requirements 

Processor 

 Intel Core 2 Duo 2.4 Ghz or faster 

Operating System 

 Microsoft® Windows® 7 (32-bit and 64-bit) 

 Microsoft® Windows® 8 (32-bit and 64-bit) 

 Microsoft® Windows Server® 2008 or 2012 
 Supports Citrix XenApp/XenDesktop/Terminal Services 

 

Memory 

 2GB or higher 

Hard Disk 

 Approximately 3 GB of available hard-disk space for installation and up to an 

additional 100MB of working space for files being converted, depending on the size of 

files being converted. 

Microsoft .NET Framework 4.5 or 4.5.1  

 http://www.microsoft.com/en-us/download/details.aspx?id=40779  

Microsoft Office 

 Microsoft® Office® 2013 (32 bit & 64 bit) 
 Microsoft® Office® 2010 (32 bit & 64 bit) 
 Microsoft® Office® 2007  

 

Microsoft Visual C++ 2005 SP1 Runtime 

 http://www.microsoft.com/en-us/download/details.aspx?id=5638 

Adobe Reader 9.1 or higher 

 http://get.adobe.com/reader 

http://www.microsoft.com/en-us/download/details.aspx?id=40779
http://www.microsoft.com/en-us/download/details.aspx?id=5638
http://get.adobe.com/reader
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Supported document types 

Extension Document type 

*.DOC 

*.DOCX 

*.DOCM 

Microsoft® Word document# 

Microsoft® Word 2007 or higher XML document 

Microsoft® Word 2007 or higher XML macro-enabled document 

*.DOT 

*.DOTX 

Microsoft® Word document template# 

Microsoft® Word 2007 or higher document template 

*.MSG Microsoft® Outlook email message 

*.PDF Portable Document Format document 

*.PPT 

*.PPTX 

*.PPTM 

Microsoft® PowerPoint presentation# 

Microsoft® PowerPoint 2007 or higher presentation 

Microsoft® PowerPoint 2007 or higher macro-enabled presentation 

*.RTF Rich Text Format document 

*.TXT Text file document 

*.XLS 

*.XLSX 

*.XLSM 

*.XLSB 

Microsoft® Excel workbook# 

Microsoft® Excel 2007 or higher XML workbook 

Microsoft® Excel 2007 or higher XML macro-enabled workbook 

Microsoft® Excel 2007 or higher binary workbook# 

NOTE:  # Microsoft Office 2007 or higher required 
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Supported integrations 

System Supported version(s) 

Microsoft® Office, incorporating Microsoft® Outlook 2007 or higher 

Document Management System integrations 

Document management systems 

eDocs DM (Open Text®) DM 5.3, 5.3.1 

HP Worksite Worksite 8.5, 9.0 

Worldox® GX3 

netdocuments® 2012 R1 , 2012 R2 & 13.2 
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Copyright © 2003 - 2013 DocsCorp Pty Ltd – All rights reserved. 

 

This program is licensed to be installed on the number of workstations shown.  compareDocs cannot 

be installed simultaneously on any more workstations than that specified, regardless of the location of 

those workstations.   

compareDocs is protected by copyright law and international treaties.  Unauthorized reproduction or 

distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and 

offenders will be prosecuted to the maximum extent possible under law. 
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